Language selection

  • English

Releases

Important

Releases will soon start to appear for Drupal 8 once stable releases are made.

Release Created Date Description
2.2.18 2019-04-24T20:38:23Z

Security update: * Update Drupal Core to 8.6.15 * SA-CORE-2019-005 * SA-CORE-2019-006

Features/Updates: - Update Drupal Core to 8.6.15 - Update Lightning to 3.2.8 - Update entityqueue to 1.0-beta2 - Update migrate_plus to 4.2

Upgrade path:

  • Update your codebase:

    • composer update
  • Run database updates:

    • drush cache:rebuild
    • drush updatedb
  • Run Lightning configuration updates:

    • drush cache:rebuild
    • drush update:lightning
2.2.17 2019-03-30T19:41:26Z Features/Updates:

  • Minor README.md improvements
  • Patch for Paragraphs endless loop
  • Revert menu_breadcrumb to 1.7 + lock
  • Update wxt_bootstrap to 1.9
    • Resolve additional issues with gcweb legacy port
  • Update wxt_bootstrap to 1.6
    • Add guard for language detection in search block
2.2.16 2019-03-22T01:21:09Z

Security update:

Features/Updates:

  • Update Lightning to 3.2.7
  • Update entityqueue to 1.0-alpha8
  • Update menu_breadcrumb to 1.8
  • Update paragraphs to 1.7
  • Update wxt_bootstrap to 1.8
    • Resolve issues with container class logic in regions
2.2.15 2019-03-15T00:35:22Z

Features: - Update Drupal Core 8.6.11 - Support for gcweb (canada.ca) theme v5.0.1 spec - Updated WxT related packages - drupal/wxt_library including: - wet-boew/theme-gcweb (v4.0.29 => v5.0.1) - wet-boew/theme-gcweb-legacy (v4.0.29) - wet-boew/wet-boew (v4.0.29 => v4.0.30) - drupal/wxt_bootstrap - Added modules - entityqueue - s3fs

Manual changes:

Upon running the database updates, the active wet-boew variant will switch to gcweb-legacy. New installs will automatically use the new gcweb variant.

If you wish to remain on the gcweb-legacy variant, and you have custom templates with gcweb in the name, rename gcweb to gcweb-legacy. To use the new gcweb variant, switch the active wet-boew variant to Canada.ca (gcweb).

Upgrade path: - Update your codebase: - composer update

  • Run database updates:
    • drush cache:rebuild
    • drush updatedb (switches to gcweb-legacy opt in for newer gcweb v5.0.1)
2.2.14 2019-02-20T23:37:54Z

Security update:

  • Update core to 8.6.10 as per SA-CONTRIB-2019-014
  • Update contribs also affected
    • Font Awesome Icons - Critical - Remote Code Execution - SA-CONTRIB-2019-025
    • Paragraphs - Critical - Remote Code Execution - SA-CONTRIB-2019-023
    • Metatag - Critical - Remote code execution - SA-CONTRIB-2019-021
    • JSON:API - Highly critical - Remote code execution - SA-CONTRIB-2019-019

Features: - Update Lightning 3.2.6

Upgrade path: - Update your codebase: - composer update

  • Run database updates:

    • drush cache:rebuild
    • drush updatedb
  • Run Lightning configuration updates:

    • drush cache:rebuild
    • drush update:lightning
2.2.13 2019-02-12T11:09:07Z

Security update:

  • Update Lightning to 3.2.5; includes:
    • Security updated Acquia Connector to 1.16 (SA-CONTRIB-2019-014)

Features/Updates: - Update Drupal Core 8.6.9 - Update Lightning 3.2.5; includes: - Updated Consumers to 1.8. - Updated JSON:API to 2.1. - Updated Moderation Dashboard to 1.0-beta1 (from previous lightning release) - Update ckeditor-codemirror 2.2 - Update webform_migrate 1.1 - Update font_awesome to 2.10 - Add s3fs 3.0-alpha13

Fixes - Apply patch (migrate_tools/3024399) to fix various drush migrate-import issues - Lock ctools to 3.0

Upgrade path:

  • Update your codebase:

    • composer update
  • Run database updates:

    • drush cache:rebuild
    • drush updatedb
  • Run Lightning configuration updates:

    • drush cache:rebuild
    • drush update:lightning
2.2.12 2019-01-17T02:08:06Z Security update(s):

2019-01-10T21:38:14Z

Security Updates: - bootstrap Security Update: - bootstrap 8.x-3.16 via wxt_bootstrap 8.x-1.6 - includes SA-CONTRIB-2018-073 from bootstrap 8.x-3.14 - jsonapi Security Update: - jsonapi 8.x-2.0-rc4 via lightning 8.x-3.2.3 - includes SA-CONTRIB-2018-081

Features: - Lightning 3.2.3 - Drupal Core 8.6.5 - Added module - fontawesome 2.9 (closes 3021451)

  • Updated wxt related packages

    • drupal/wxt_library (1.3.0 => 1.4.0) including:
    • wet-boew/theme-gcweb (v4.0.28.1 => v4.0.29)
    • wet-boew/theme-wet-boew (v4.0.28.1 => v4.0.29)
    • wet-boew/wet-boew (v4.0.28.1 => v4.0.29)
    • wxt_bootstrap (1.5.0 => 1.6.0) including:
    • bootstrap (3.12.0 => 3.16.0)
  • Updated contrib modules

    • admin_toolbar (1.24.0 => 1.25.0)
    • config_update (1.5.0 => 1.6.0)
    • entity_reference_revisions (1.5.0 => 1.6.0)
    • inline_entity_form (1.0.0-beta1 => 1.0.0-rc1)
    • migrate_plus (4.0.0 => 4.1.0)
    • migrate_tools (4.0.0 => 4.1.0)
    • webform (5.0.0 => 5.1.0)
  • Removed patches that no longer apply

  • now loading wet-boew dependencies with composer repo drupalwxt/composer-extdeps

Upgrade path:

  • Update your codebase:

    • composer update
  • Run database updates:

    • drush cache:rebuild
    • drush updatedb
2.2.1 2018-11-13T17:02:13Z Fixed an issue with a patch to comments redirect within drupal-core.
2.2.0 2018-11-07T21:05:48Z

Security Update(s):

Feature(s):

  • Lightning 3.2.2
  • Drupal Core 8.6.2
  • Updated contrib modules
    • paragraphs to 1.5
    • views_bootstrap to 3.1
    • bootstrap to 3.13
    • media_entity_instagram to alpha2
  • Removed patches that no longer apply
  • Updated and refactored some patches to work with drupal core 8.6.x

Upgrade path:

  • Update your codebase:

    • composer update
  • Update sub-profile info.yml file to look similar to wxt.info.yml

name: My Profile
core: 8.x
type: profile
base profile: lightning
install:
  - paragraphs
  - slick_entityreference
exclude:
  - lightning_search
  - pathauto
  - bartik
  • Run database updates:

    • drush cache:rebuild
    • drush updatedb
  • Run Lightning configuration updates:

    • drush cache:rebuild
    • drush update:lightning
2.1.9 2018-10-28T17:33:40Z

v2.1.9

Security Update(s):

2.1.8 2018-08-29T20:44:43Z

v2.1.8

Feature(s) / Bug fixe(s):

  • Removes patches that are no longer necessary
  • Updated wxt_bootstrap to 1.5
    • Update bootstrap to 3.12
  • Updated wxt_library to 1.3
    • Update wet-boew packages to 0.28.1 (where available)
2.1.7 2018-08-02T01:52:35Z

Security update(s):

Feature(s) / Bug fixe(s):

  • Updated wxt_bootstrap to 1.4
    • Form required marker “\204E” is broken in Chrome on Windows (#2988183)
    • Use img elements for SVG images instead of object elements (#2990023)
  • Landing page behat test fail with moderation_state (#2989354)
2.1.6 2018-07-15T16:03:58Z

Features / Bug Fixes:

  • Updated Drupal Core to 8.5.5
  • Updated wxt_library to 1.2
    • Fix Cache issues in user account block (#2980764)
    • Fix Update search Canada.ca form for HTTPS (#2977233)
  • Updated wxt_bootstrap to 1.3
    • Add CDN option for the footer to the theme settings (#2927929)
  • Updated contrib modules, including:
    • admin_toolbar to 1.24
    • block_class to 1.0
    • bootstrap_layouts to 5.1
    • diff to 1.0-rc2
    • media_entity_image to 1.3
    • media_entity_slideshow to 2.0-alpha1
    • menu_block to 1.5.0
    • field_formatter to 1.2
    • metatag to 1.5
    • migrate_tools to 4.0-rc1
    • token_filter to 1.0
    • webform to 5.0-rc16

Note: After updating, Drupal will emit a warning about the metatag_page_variants module missing. This will be corrected by an update hook in wxt_ext_metatag when drush updb is run.

2.1.5 2018-06-07T14:05:00Z

v2.1.5

Feature(s):

  • Lightning 3.1.4
  • Update contrib modules
Date modified: